Vulnerabilities in OpenSSL

Oct 15, 2007

Three security issues have been identified in the Open Source implementation of the SSL/TLS protocol, OpenSSL. The vulnerabilities allow targeted attacks.

Developer Andy Polyakov discovered a vulnerability (CVE-2007-4995) in OpenSSL that attackers can exploit for denial of service attacks. The bug, of which details have not been disclosed, affects the DTLS implementation. A successful attack would allow a hacker to execute arbitrary code. The vulnerability only affects systems that use DTLS. All 0.9.8 versions up to but not including 0.9.8f are affected, as are 0.9.7 through 0.9.7m.

A second vulnerability has been identified and published under CVE-2007-5135. An off-by-one error in the "SSL_get_shared_ciphers()" function provokes an overflow with a currently unknown effect. The feature is typically used for logging and debugging purposes.

A third vulnerability, which was identified awhile back (CVE-2007-3108), affects the incorrect implementation of Montgomery multiplication in the "crypto/bn/bn_mont.c" function. The bug could give local users the ability to launch side channel attacks and thus capture RSA private keys.

Users are advised to update to the current 0.9.8f version to close the first vulnerability, and to rebuild any packages that use DTLS. If this is not available as an option, the OpenSSl developers suggest disabling DTLS. Damage caused by the second vulnerability can be prevented by not using the affected feature. Updated packages that close all three security holes are available for Red Hat.

Related content

comments powered by Disqus

Issue 166/2014

Buy this issue as a PDF

Digital Issue: Price $9.99
(incl. VAT)

News