Ask Klaus!

Ask Klaus!

Article from Issue 105/2009

Interrupted Upgrade


I am new to Linux. I recently installed Ubuntu in a dual-boot configuration on my desktop. My existing OS was Windows XP, SP3. After a while, I received a notification on screen (I was running Linux at the time) that Ubuntu 9.04 was available for downloading. I agreed and started the download/installation.

Everything went fine until the system encountered the Moodle program that I installed for later tinkering. When it did, it asked for the FQDN. Since I am not running Ubuntu as a server, I attempted to bypass this information… Bad choice.

Now Ubuntu will not fully boot. I get to a white screen and the OS will not finish loading. Do I need to run an ISO image that I have of 9.04?

Can I run the ISO to remove Moodle? What would you recommend?


Based on your report, I believe the problem is not really Moodle, but rather an interrupted installation or upgrade process. Apparently, the system is still in a bootable state, so the rescue procedure should not require booting from a Live CD/DVD and accessing your installation via mount and chroot.

But since the graphical mode seems to be out of order from the incomplete update, you will have to use text mode for repair until Xorg can start normally again.

Please tell your system to start without the graphical interface in the bootloader, which will most likely work using the following boot option:

linux vga=normal single

which boots into single-user (administrative) mode. An alternative is linux vga=normal 2 for getting a few more text consoles.

You should get a root shell, possibly after having answered the request for a root password correctly.

Make sure your root filesystem is mounted read/write:

mount -o remount,rw /

and then you can begin with cleanup and repair.

You could deinstall Moodle at this point:

dpkg --purge moodle

but again, this is probably not going to fix the problem.

If you started in single-user mode, your network is probably down, so the next command might fail to get any missing files from the Internet. Anyway, you can try:

aptitude -f install


apt-get -f install

which will try to bring your system into a consistent state again.

If it seems that aptitude or apt-get will try to remove too many important packages, you should answer the prompt about whether to proceed with a "N" for No and then try:

aptitude safe-upgrade


apt-get upgrade

to restart the update that has caused the system failure.

Conflicts or inconsistencies shown during this procedure (which can safely be restarted at any time later) could be solved by removing the conflicting packages with the dpkg --purge command. If you want to keep the configuration files of programs you remove, use dpkg -r packagename, which will only remove non-configuration data (at least, it is supposed to).

In the worst case, you will have to reinstall all xorg-* packages and corresponding libraries to fix your graphics. You can get a listing of packages with the following:

dpkg -l

Don't forget to cleanly shut down the system after everything is done, or at least, use the sync command, or, even better:

mount -o remount,ro /

should ensure that all data is written before any reset occurs.

Wireless Woes


I'm hoping you can provide me with some troubleshooting help. I am using the latest Knoppix 6.1 DVD that I got from Linux Magazine. I am using an Intel 3945 a/b/g chip. An unsecured access point in my area, belkin54g, tries to associate with my system. Afterward, when I scan iwlist wlan0 scanning, it only finds one AP, not the belkin54g. If I intervene during the boot and manually switch off the wireless, it scans normally.

I'm including the files for you to look over. In the past I've run Kismet, and the belkin54g is possibly transmitting forced probes. It appears to affect Vista so much that, even when I delete the belkin54g AP from Manage Networks, it regrabs on to it.


If you noticed this problem first in the Knoppix 6.1 DVD, it is probably a NetworkManager issue, so this is a good occasion for a general discussion of the NetworkManager tool (version 0.7 as of now). NetworkManager is a quite new, and it is still a work in progress, but it is already used in many distributions as a front end to the standard network tools ifconfig, iwconfig, and wpa_supplicant. Unlike these common command-line-based Unix/Linux tools, NetworkManager does many things on its own with roaming in mind: When relocating your computer or plugging in cables or other wireless adapters, NetworkManager decides on its own which connection is likely to match your current setup best. The "busy" animation appears in your taskbar at the bottom of your screen until NetworkManager's detection process finds a LAN and acquires an address via DHCP, or else until a "strong enough" wireless signal is detected, in which case, NetworkManager connects to the corresponding access point.

The main advantage of NetworkManager is that it makes connection to a wireless or cable network very quick and easy for beginners.

Because NetworkManager permanently runs a DHCP client on various devices, which do their own scanning and interfere with programs like Kismet, iwconfig, and wavemon, the main disadvantage is that Network Manager keeps some of the tools that more technically oriented users use for network debugging and measurement from working. Even Debian's standard method of connecting ifup/ifdown will no longer work reliably once NetworkManager is configured to also use devices listed in /etc/network/iterfaces (which is the case in Knoppix 6.1).

This means that, as long as NetworkManager is running, all other network tools are most likely unreliable both in their configuration and in the results they display. Even manually configuring /etc/wpa_supplicant/wpa_supplicant.conf will no longer work.

One solution is to kill NetworkManager and its associated daemon:

sudo /etc/init.d/network-manager stop
sudo killall nm-system-settings

and then use your favorite wireless tools. Please note that just ending NetworkManager's main process is not enough, because nm-system-settings continues to run independently in Debian and keeps devices busy.

Another possibility for the more GUI-oriented user is getting NetworkManager to do what you want rather than shutting it down.

Before your start tinkering, though, keep in mind that NetworkManager's security policy settings require any user interacting with it to be in the Unix group netdev (check with the id command if you are unsure); otherwise, it just won't react to any user-initiated configuration attempts, no matter what you do.

NetworkManager's front end, nm-applet, runs inside the desktop panel, actually an "easy" configuration mode (network selector), which you get by clicking the left mouse button over the nm-applet icon (Figure 1).

Once NetworkManager connects to one network, it might or might not continue to detect and display additional networks depending on the wireless driver. Access points that don't broadcast their ESSID (this is called "hidden mode") will not show up in the scan list. You can find and connect to them using the Connect to Hidden Wireless Network menu item, which will allow you to enter the ESSID as well as the desired access points hardware address, if necessary (Figure 2).

Another way of entering new wireless networks instead of waiting for them to appear automatically is by calling the "extended settings" right-mouse button menu on nm-applet (Figure 3).

You can then jump right into the connection editor, which allows you to enter new connections or modify existing connections (Figure 4).

The gnome-style nm-* tools store their setting within gconf, in subdirectories and .xml-files under $HOME/.gconf/system/networking/connections/*. The NetworkManager system-wide settings can be either stored in /etc/NetworkManager/system-connections (which is most likely never used because of permission/policy restrictions) or via the ifupdown plugin, which allows definitions of connection settings through /etc/network/interfaces once the following settings are present in /etc/NetworkManager/nm-system-settings.conf:


With a setting like this, the following entry in /etc/network/interfaces will be accepted by NetworkManager as a valid system-wide connection:

auto my_network
iface my_network inet dhcp
       wpa-driver wext
       wpa-ssid my_essid
       wpa-key-mgmt WPA-PSK
       wpa-psk my_secret_wpa_passphrase

Note that, unlike what you might be used to when creating interface descriptions in /etc/network/interfaces, a NetworkManager connection is device-independent, so you just use virtual device names (like my_network in this example), and let NetworkManager decide on its own which actual wireless device to use in order to actually make the connection.

With this configuration, please avoid manually calling ifup or ifdown while running NetworkManager to avoid the complication of concurrent DHCP clients fighting each other.



I am using Ubuntu 7.10 and have gtk-recordMyDesktop installed. I use Select Window to select the window I would like to record. But when I click on the Record button in an effort to record the selected window, it pops up the message Recording is finished. recordMyDesktop has exited with status: 768. Description: Could not open/configure sound card.

Any idea how to fix this issue?


RecordMyDesktop is supposed to capture parts of the screen and store them in video files, typically for educational and documentation purposes. In addition to the image, you can add commentary using a microphone or a different sound input resource, and this appears to be the source of your problem.

The sound device is already in use by a different program, and the sound driver your system uses is not capable of concurrent access to the sound hardware in the form of a software mixer.

One solution to this problem is to just record without sound by disabling sound recording. You will need to uncheck the checkbox in front of the sound quality slide in the gtk-recordMyDesktop GUI (Figure 5).

Another option is to find and eliminate the source of the problem that is blocking access to the audio device. A very common case is a running sound-daemon, Internet telephony, or a Flash or Java applet accessing the sound device and keeping /dev/dsp busy – usually in write-mode for playing sound, but sometimes also in read-mode when recording from a microphone or line-in.

Useful commands for finding the process that is causing the problem are:

fuser -v /dev/dsp


fuser -v /dev/audio

If you would like to record a music-editing session with a program such as Audacity or another multimedia editing tool, chances are that the sound device is taken and additional parallel recording of sound is just not possible.

In this case, you will have to choose the first solution and re-insert sound or commentary at a later time using a video-editing tool like Kino for postprocessing.

Buy Linux Magazine

Get it on Google Play

US / Canada

Get it on Google Play

UK / Australia

Related content

  • Dispatcher Scripts

    Use dispatcher scripts to mount a different network drive depending on the location or automatically start a VPN connection without lifting a finger.

  • NetworkManager 0.7.1 Power-Saving

    On the project mailing list, Dan Williams announced the new version 0.7.1 of NetworkManager that provides a bunch of enhancements.

  • Networking

    What good is a laptop or desktop that's not connected to the Internet? Sure, you could do a few things with it, but these days a machine that's not online might as well be a paperweight.

  • iNet Wireless Daemon

    Intel's iNet wireless daemon offers virtually all of the features found in the obsolete WPA Supplicant, and it is smaller by a factor of 10.

  • Cross-Platform VPN Connections

    Linux clients sometimes need a little help to connect to Windows VPN servers.

comments powered by Disqus