Manage Flatpak, Snap, and AppImage packages with bauh

All-in-One

© Photo by Natalie Rhea Riggs on Unsplash

© Photo by Natalie Rhea Riggs on Unsplash

Article from Issue 236/2020
Author(s):

The bauh package manager can cope with Flatpaks, Snaps, AppImages, AUR, and native web apps.

Old-school Linux package formats like deb and RPM let you install an application with a couple of commands or mouse clicks – as long as all the dependencies are satisfied. If dependencies are missing, things get a bit more complicated, with the package manager chasing down additional packages and sometimes choking if a package isn't found or there is a version number conflict.

Next-generation tools like Snap, Flatpak, and AppImage have solved the dependency problem by packing dependencies with the package. Because they carry their dependencies with them, these modern-day formats are largely portable, installing on any Linux system as long as it has a compatible package manager.

But why so many formats? In the grand tradition of Linux, the community has solved the same problem several different ways. Does that mean you need several different package managers to read Snap, Flatpak, and AppImage formats?

Not anymore. Bauh [1] is a graphical package manager that can handle Snap, Flatpak, and AppImage formats from a single user interface. Bauh, which, your Brazilian friends will tell you, is pronounced ba-oh, meaning box or drawer, evolved from the Arch Linux fpakman package tool and also supports the Arch User Repository (AUR) package format. The bauh user interface lets you search for and install applications, install updates, delete unnecessary programs, and view the installation history.

Getting Started

On Arch Linux and its derivatives, you can install bauh via the user archive AUR by typing:

yay -S bauh

On Debian, Ubuntu, and their derivatives, install bauh using the pip installer from the Python universe. First, set up the required dependencies, which you will find in a list [2] on GitHub. Then type

sudo apt install python3-pip

to install Python3 pip, where you will then finally type the command for installing bauh:

sudo pip3 install bauh

In the next step, if you have not already done so, take care to install the bases for the package formats you want to manage with bauh. Flatpak is easiest to install directly from the Flathub [3] website, a central repository for Flatpaks. When you get there, click on the button labeled Quick Setup and in the next step select Debian, Arch Linux, or one of the distributions based on it. You will then receive instructions on how to install the Flatpak basics including the Flathub repo.

To be able to manage Snaps with bauh, you need to install snapd. Ubuntu from version 16.04 on, Solus 3, and Zorin OS already include the service out-of-the-box; installation instructions for other distributions are available on the Snapcraft website [4]. After installing snapd, you need to log out and back in, or reboot the system, to adapt the required environmental variables. As a functional test for Debian, try installing the Snap Store, using:

sudo snap install snap-store

AppImage is an older format that is becoming more and more popular due to the popularity of Flatpak and Snap. Bauh can only be used with apps that are offered via the AppImageHub [5] and are simultaneously hosted on GitHub. This includes over 1,000 programs, as you can see on AppImageHub. The dependencies on Debian, for example, are sqlite3 and wget, while Arch Linux needs sqlite and wget. Alternatively, for fast downloads with several threads, you can install the aria2 download manager.

On systems with Arch Linux, bauh additionally supports the AUR. The archive maintained by the distribution's community supports the integration of packages not officially available in Arch, much like a collection of recipes. As a prerequisite for the AUR, you need pacman and wget; here again, aria2 supports faster downloads.

Finally, bauh supports the integration of web apps. If you select this option, the system will automatically import some required dependencies, including Node.js, Electron, and nativefier [6]. You have to make sure that python-lxml and python-beautifulsoup4 are installed on Arch, and beautifulsoup4 and lxml on Debian. The two packages are not available in the Debian archives, so you will need to install them with pip as described earlier.

Configuration

Once you have fulfilled all the requirements for the desired formats, launch bauh. Start by clicking on the blue gear wheel in the bottom right corner and then on Application types. The window that opens should now show all the supported formats (Figure 1). These can be (de)activated in this window as required. If the list does not contain the desired formats, you need to recheck the dependencies.

Figure 1: Use the gear wheel on the bottom right to display the supported formats and switch the individual formats on and off as required.

After first launching bauh, which was developed in Python 3 and Qt5, the application automatically finds all previously installed applications belonging to the formats whose support you have unlocked and whose prerequisites and dependencies are met on the system (Figure 2). The central configuration file goes by the name of bauh.yml and is located in ~/.config/. In the file, you can specify, for example, whether bauh should display a tray icon, whether the icon should notify you in case of updates for managed apps, or how many suggestions for apps the package management program should display.

Figure 2: Immediately after the first launch, bauh will show you all applications belonging to the enabled activated formats that already exist on the system.

For the Non-Admins

The latest version, bauh 0.9.3, supports the installation of Flatpaks globally for the system, but you can also opt to install for the user. Installing for the end user has the advantage that normal user privileges are all you need to install or update packages. We encountered a minor problem on Debian with this feature that was not bauh's fault but rather Flatpak's.

When installing a Flatpak with bauh, you are prompted to decide whether to install the package globally or as a user. On Debian, installing as a user did not succeed; an error message indicated missing permissions. To work around this problem, you need to change the permissions in /var/tmp/ from 755 to 1777. To do this, use the command:

sudo chmod 1777 /var/tmp

The important thing here is the 1 in the first digit. It stands for the sticky bit, an extended file right. The sticky bit restricts access to files in a directory. If the bit is set, only the owner of the file or directory is allowed to delete or rename the corresponding object. This does not affect the rights to write, read, and execute the file.

Buy this article as PDF

Express-Checkout as PDF
Price $2.95
(incl. VAT)

Buy Linux Magazine

SINGLE ISSUES
 
SUBSCRIPTIONS
 
TABLET & SMARTPHONE APPS
Get it on Google Play

US / Canada

Get it on Google Play

UK / Australia

Related content

  • FOSSPicks

    This issue's copy was almost late after Graham rediscovered just how immersive and addictive the 1997 game, Blade Runner, can be when recreated on the latest release of ScummVM. Plus, Graham explores Blender 2.8, Amass, Cookbook, Mangl, Cawbird, Chiaki, and more!

  • Flatpak and Snap

    The new container-inspired package formats Flatpak and Snap have landed in the territory occupied by conventional Linux package systems such as RPM and Dpkg.

  • Chob

    If you are looking for an application in AppImage, Flatpak, or Snap app stores, Chob lets you perform a keyword-based search from the command line.

  • Universal Package Systems

    Billed as the future of package management, universal package systems like Snappy and Flatpak have failed to live up to their promise.

  • Introduction

    This month in Linux Voice.

comments powered by Disqus