Adobe Updates Flash Player to Fix Huge Security Hole

Dec 19, 2008

Adobe recommends that Linux Flash Player users immediately upgrade to the newest versions.

The critical vulnerability affects Flash Player for Linux versions 10.0.12.36 and 9.0.151.0 (and earlier). An attacker can potentionally take control of a system with the help of specially formed SWF data that the user might have loaded. To verify your Flash Player version, enter "about:plugins" in the browser's address line, or right-click some Flash content and select "About Adobe (or Macromedia) Flash Player" from the menu.

Adobe advises upgrading to the newest version 10.0.15.3 for Linux. For earlier versions, upgrade to 9.0.152.0, available at another download site.

Seeing that Flash content is widespread over Web, many Linux users run the Flash Player, albeit warily in light of such recurring security problems. You can upgrade often just to be sure, or you can run Gnash, except that it doesn't yet include all the Flash Player 10 features. A compromise for Firefox users is to install Mozilla's Flashblock add-on so that you can choose which Flash content to play and thereby reduce exposure to the potential vulnerability.

Related content

comments powered by Disqus

Issue 170/2015

Buy this issue as a PDF

Digital Issue: Price $9.99
(incl. VAT)

News