Query domain information with RDAP
At Your Fingertips
RDAP provides structured information about domains. Besides practical command-line query tools, there are also libraries for integrating the protocol into your own programs.
Since the early days of the Internet and its division into different organizational areas, users have needed a way to obtain information about domains, the IP addresses they use, their owners, and a way of mapping them to each other. The WHOIS protocol was devised for this purpose in 1982 and introduced in RFC 812 [1]. The service can be accessed using a command-line tool of the same name, whois. The age and importance of the protocol are evident from, among other things, its very low number – 43 – in the list of standardized ports for network services [2], which can be found in the file /etc/services [3].
Thus far, this plain-text protocol has proven its value thanks to its simplicity, even if only request and response have been standardized in a fairly rough framework. The last update in RFC 3912 dates back to 2004 [4]. (See the "Regulations on WHOIS in Europe" box for details on that topic.) The search for a replacement has been underway for some time. The ideal candidate is the Registration Data Access Protocol (RDAP) [6], which is defined in more detail in RFC 9082 [7].
RDAP
The idea is for RDAP to completely replace WHOIS. It provides information about a domain via the HTTP protocol. This eliminates the need to open port 43 in the firewall. RDAP was standardized back in 2015 by an Internet Engineering Task Force (IETF) working group.
[...]
Buy this article as PDF
(incl. VAT)
Buy Linux Magazine
Subscribe to our Linux Newsletters
Find Linux and Open Source Jobs
Subscribe to our ADMIN Newsletters
Support Our Work
Linux Magazine content is made possible with support from readers like you. Please consider contributing when you’ve found an article to be beneficial.
News
-
Working Exploit for a Linux Kernel Flaw Made Public
Even before a bug received its CVE identifier or an upstream fix, the local privilege escalation vulnerability exploit found its way into the wild.
-
r/opensource Bans AI-Assisted and AI-Related Projects
The de facto subreddit for all things open source has not only banned AI-related projects but also users who "don't speak English."
-
Bottlenecks Discovered by Meta Engineers Lead to Scalability Improvements
Thanks to a small group of engineers at Meta, the Linux kernel module kernfs has been improved, which has led to some serious gains.
-
PwnEscape Poses VM Vulnerability
A guest-to-host escape flaw in Linux KVM, named PwnEscape, might be yet another means of attacking Linux.
-
Linux Mint 27 Set for a Christmas Release
The developers behind Linux Mint have announced a Christmas release, and it looks like Santa's sack will be brimming with features.
-
Is Linus Torvalds Vibe Coding?
The creator of Linux has added AI into his process for Linux kernel development, and it's more than just for debugging.
-
openKylin 3.0 Released with Expanded AI Integration
The latest release features a pre-installed AI agent to help perform tasks.
-
DigitalOcean Ends Open Source Credits Program
In a change that has surprised many open source developers, DigitalOcean has decided to sunset its Open Source Credits Program.
-
Office 365 Available for Testing on Linux via Bottles
Linux users can now test the official Office 365, thanks to Mirko Brombin's work on Bottles.
-
Dutch Government Turns to Open Source for Digital Sovereignty
Following in the footsteps of other European countries, the Netherlands is looking to increase its sovereign digital infrastructure with open source software.
